Why I got such message,The following packages cannot be authenticated?

Posted on Updated on


Apakah anda juga pernah mengalami hal yang sama? mendapatkan message warning “The following packages cannot be authenticated” setiap kali menginstall program menggunakan apt-get 0.6.x ?

debian:~# apt-get install tcpflow
Reading package lists… Done
Building dependency tree… Done
Suggested packages:
tcpdump
The following NEW packages will be installed
tcpflow
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 0B/23.6kB of archives.
After unpacking 86.0kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
tcpflow
Install these packages without verification [y/N]?

Ini adalah normal, seperti keterangan “Jordi Mallach Pérez” salah satu developer debian.org disini

Pertanyaan yang akan muncul adalah, bagaimana supaya message itu tidak muncul kembali?

Jawabannya adalah dengan menambahkan APT::Get::AllowUnauthenticated “true”; pada apt.conf Anda.

debian:~# cat /etc/apt/apt.conf.d/70debconf
// Pre-configure all packages with debconf before they are installed.
// If you don’t like it, comment it out.
DPkg::Pre-Install-Pkgs {“/usr/sbin/dpkg-preconfigure –apt || true”;};
APT::Get::AllowUnauthenticated “true”;

kemudian cobalah menggunakan apt-get untuk menginstall program yang anda inginkan, insyaAllah message warning itu tidak akan muncul kembali.

debian:~# apt-get install tcpflow
Reading package lists… Done
Building dependency tree… Done
Suggested packages:
tcpdump
The following NEW packages will be installed
tcpflow
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 0B/23.6kB of archives.
After unpacking 86.0kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
tcpflow
Authentication warning overridden.
Selecting previously deselected package tcpflow.
(Reading database … 128821 files and directories currently installed.)
Unpacking tcpflow (from …/tcpflow_0.21-8_i386.deb) …
Setting up tcpflow (0.21-8) …

Good Luck🙂

One thought on “Why I got such message,The following packages cannot be authenticated?

    paijo said:
    June 8, 2010 at 6:10 pm

    menurut saya, mengubah menjadi true
    DPkg::Pre-Install-Pkgs {“/usr/sbin/dpkg-preconfigure –apt || true”;};
    APT::Get::AllowUnauthenticated “true”;
    bukan cara yang bijak..karena memperbolehkan installasi dari sumber “yang belum tentu dipercaya”…

    di http://wiki.debian.org/SecureApt kayaknya ada petunjuknya..
    salam..

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s